Robocode Editor/Compiler troubles?

Fragment of a discussion from User talk:Sheldor
Jump to navigation Jump to search

I've noticed that strange things happen in the initialization code, for instance it runs my FastTrig init code in the Robocode startup, and if I put System.out.println() statements there they will be printed to the main console. I've been meaning to put in a bug report about this for a while now...

My suggestion is get rid of all the bots you don't need, and start with an empty install. Copy them in a few at a time until you figure out what is going wrong. Maybe just keep your own dev (ie. robocode/robots/sheldor/) directory, and keep extracted bots in a different directory that Robocode doesn't know about. BTW, putting bots in a .zip won't work, since new Robocodes look inside of .zip files for bots.

Skilgannon16:30, 21 March 2013

I tried your suggestion. Robocode still gets the errors, but now it goes through them in a matter of seconds, which I can accept.

Whenever I tried the Robot Editor, I got this message:

Please wait while Robocode sets up a compiler for you...

Setting up compiler
Java home is <CENSORED>\jre6

Testing compile with Java Compiler (javac)
Java Compiler (javac) does not exists or cannot compile.
Testing compile with Eclipse Compiler for Java (ECJ)
Eclipse Compiler for Java (ECJ) was found and is working.

Compiler has been set up successfully.
Click OK to continue.

I assume I deleted something important when I was deleting robots, that Robocode had to rebuild, or search for and update references, or something else like that.

Anyway, Robocode works for me now (though testing will be a bit harder), so I thank you all for your help.

Sheldor22:23, 26 April 2013

Try calling "javac" from the command-line and see if it works.

MN14:48, 27 April 2013

Why? The "Eclipse Compiler for Java" is working fine.

Sheldor20:34, 27 April 2013

To track why you still get errors, only that. Eclipse compiler is just as good, if not better, than JDK compiler.

MN12:01, 28 April 2013